QNX perspectives

Perspectives control which views are shown in the IDE and how they are laid out. The IDE contains many perspectives that support application and system analysis for QNX Neutrino targets.

Here, we list only those perspectives and views designed for working with QNX targets. The default perspective is the C/C++ perspective, which is described in “Perspectives available to C/C++ developers” in the C/C++ Development User Guide. General information about perspectives is given in “Working with perspectives” in the Workbench User Guide.

To open a specific view, select Window > Show View > Other, then expand the entry for the current perspective and select the view that you want to open. You can also reset the perspective to its default views by selecting Window > Perspective > Reset Perspective.

Table 1. QNX perspectives and associated QNX views
Name Description Associated QNX views
QNX Analysis

Displays data produced by analysis sessions.

The IDE opens this perspective when you launch an application in any of the Coverage, Memory, Profile, or Check launch modes. In a new session, the IDE stores the analysis results. In one or more views, it displays a visual representation or statistics based on these results.

Analysis Sessions
Execution Time
Memory Backtrace
Memory Events
Memory Problems
Valgrind

QNX System Information

Provides detailed realtime data about your target machine's resource allocation and usage, along with key metrics such as CPU usage, program layout, the interaction of different programs, and more.

You should open this perspective when you want to examine the current state of your target.

APS View
Connection Information
Malloc Information
Memory Information
Process Information
Signal Information
System Resources
System Summary
Target File System Navigator
Target Navigator

QNX System Profiler

Displays the results of kernel event traces and the statistics gathered during them. You can view the visual representation of the content in kernel event log (.kev) files and gain insight into the system activity and process interaction that occurred during the trace period.

The data read by the System Profiler is generated by the instrumented QNX Neutrino kernel, procnto*-instr, then written to a log file by a data capture program on the target, before being read in and displayed by the IDE.

Client/Server CPU Statistics
Condition Statistics
Event Data
Event Owner Statistics
Filters
General Statistics
Target Navigator
Thread Call Stack
Thread State Snapshot
Timeline State Colors
Trace Event Log
Why Running?