Downloading an image to your target

Many boards have a ROM monitor, a simple program that runs when you first power on the board. The ROM monitor lets you communicate with your board via a command-line interface (over a serial or Ethernet link), download images to the board's system memory, burn images into flash, etc.

Note: If your board doesn't have a ROM monitor, you probably can't use the download services in the IDE; you'll have to get the image onto the board some other way — JTAG, for example. To learn how to connect to your particular target, consult your hardware and BSP documentation.

Open a serial terminal

The IDE includes a Terminal view so you can talk to your target and download images without having to leave the IDE and use an external program like HyperTerminal.

To open a serial terminal and talk to your target:

  1. Connect your target and host with a serial cable.
  2. From the main menu of IDE, select Window > Show View > Other...
  3. Expand Terminal, then select Terminal and click OK. The IDE displays the Terminal view, typically at the bottom right.
  4. Click the Open Terminal button (Icon: Open Terminal button) to open the following window:
    Window: Launch Terminal

  5. From the Choose terminal dropdown, select Serial Terminal, then select your communications parameters and click OK. You can now interact with your target by typing in the view.

Transfer files with the Send File button

Once you've created a serial terminal, the Send File button () becomes enabled.

To transfer a file:

  1. Configure your target so that it's ready to receive an image; you can do this through the Terminal view or through a method outside the IDE. For details, see your hardware documentation.
  2. Click the Send File button to open the Data Transmission window:
    window: Data Transmission

  3. Enter the name of your file or browse for the file in your workspace or host filesystem.
  4. Select a transfer protocol and click Finish. The IDE transmits your file over the serial connection. If you want to stop the transfer, you can click the Cancel button ().
Note: The QNX sendto protocol sends a sequence of records (including the start record, data records, and a go record). Each record has a sequence number and a checksum. Your target must be running an IPL (or other software) that understands this protocol.

Transfer files over TFTP

In addition to support for serial terminals, the IDE has a TFTP server that lets you transfer images to your board.

The IDE's TFTP server eliminates the need to set up an external server for downloading images (if your target device supports TFTP downloads). The TFTP server knows about all QNX System Builder projects and automatically searches them for system images whenever it receives requests for service.

The TFTP Server view provides status and feedback for current and past TFTP transfers. As the internal TFTP server handles requests, the view provides visual feedback. For example:

Note: If you're running as a non-root user on Linux, you need to start the TFTP server on a port higher than 2015. To set the port, select Window > Preferences > QNX > Tftp Server, enter a port number in the Port field, then click OK.

To transfer a file using the TFTP server:

  1. Select Window > Show View > Other.
  2. Expand the QNX System Builder entry, then select TFTP to open the TFTP Server view. By default, the view appears at the bottom right.
  3. Select Window > Navigation > Show View Menu > Start to start the TFTP server.

    For the remainder of the IDE session, the TFTP server listens for incoming TFTP transfer requests and automatically fulfills them.

  4. Using the IDE, configure your target for IP communications (for details, see IP communications). The TFTP Server view shows your host's IP address. During the transfer, the view also shows:
    • requested filename
    • transfer progress bar
    • transfer status message

To clear the TFTP Server view of all completed transactions, click the Clear button (Icon: Clear TFTP view).

The internal TFTP server recognizes files in the images directory of all open QNX System Builder projects, so you don't need to specify the full path.

CAUTION:
The IDE deletes the content of the images directory during builds, so don't use this directory to transfer files that the IDE didn't generate. Instead, configure a new path, as described below.

To enable the transfer of files that aren't in the images directory:

  1. Select Window > Preferences.
  2. In the left pane of the Preferences window, expand QNX, expand Tftp Server, then select User Search Paths.
  3. Click New to open the Add New Search Path window and browse to select the location for your image.
  4. Click OK, then click OK again. The TFTP server is now aware of the contents of your selected directory.

Other file transfer methods

If your board doesn't have an integrated ROM monitor, you may not be able transfer your image over a serial or TFTP connection. You'll have to use some other method instead, such as:

For more information, see the documentation that came with your board.