Supported boards and APIs

The QNX Runtime for APK supports standard APK APIs, and can be run on several popular boards,.


Currently the QNX Runtime for APK uses the Jellybean (4.2.2) release, API level 17.


Freescale i.MX6Q SABRE Lite
Due to the limited memory available on this board, we recommend that during your evaluation of the Runtime for APK you carefully monitor your use of other high-resource applications. Support of this board requires the QNX 6.6.0 Graphics GA Patch. This patch is available from our QNX Download Center.
Texas Instruments OMAP5 uEVM (ES2 Silicon)
We strongly recommend that you use fastboot with EMMC or eMMC+SATA in conjunction with the Runtime for APK. Use of an SD card can result in a slow start-up.
  • For more information about boot optimization, see the Boot Optimization Guide.
  • Runtime for APK cannot be used on the Texas Instruments Jacinto 5 (J5 Eco Rev 5) board.