Build Variants tab

The Build Variants tab lets you choose the platforms to compile executables for, and you can also click Add to specify your own custom variants, such as a unit testing variant.

Selecting a build variant on the Build Variants tab.


By default, none of the platforms are enabled. You might want to change your default preferences for all new QNX projects. To do this, open Window > Preferences > QNX > New Project > Build Variants.

For PhAB projects, the following variant types aren't supported: ARM v7, MIPS, and PPC SPE.

Select the specific architecture(s) and build variant(s) you want to build for your project. Note that QNX projects are different from managed-build projects.

To make a change to your existing variant(s), you'll need to select File > Clean and then build again, or perform the clean before you make the change to the target variant(s).

You can click the Select All button to enable all of the listed variants, or the Deselect All button to disable all of the listed variants.

You can click the Add button to add a new variant under the currently selected target architecture, or the Delete button to remove the currently selected variant.

To choose a build variant for the Indexer to use:

  1. Select the build variant for the indexer to use.
  2. Click the Set Indexer Variant button.

    The variant's name changes to include >. This variant's symbols and include paths will be used for source indexing. The impact on the C/C++ Editor is that it determines the macro definitions, inclusion/exclusion of additional code, the navigation to the deader files and so on.