Opening the online help from the IDE

To open the IDE Help:

From the main menu, select Help > Help Contents.

If the online help is not available when you open an IDE dialog, from the main menu, select Window > Preferences, expand General, select Web Browser, and then select Use external Web browser. Setting this option causes online help to be displayed in an external browser.

On some Linux systems, an external browser isn't specified in the preferences by default, and therefore it must be created manually by clicking New, specifying a name, and then clicking Browse to locate the external Web browser.

If you're using an external web browser, the IDE starts a web server running on a random port (alternatively, you can specify a port in the Preferences window using Window > Preferences… > Help > Content). You can access the help system through this port using any web browser; you aren't limited to the browser launched by the IDE.

Note: If your help system uses a random port, opening and closing the help several times can confuse some anti-spyware programs, and they may conclude that the help system is a malignant program trying to do nefarious activities with your computer. At this point, the anti-spyware program will either block the program from opening ports (which will disable the online help), or warn you about the strange activity.

Unless you're extremely low on RAM, keep the online help system open until you're finished using the IDE. This prevents any anti-spyware programs from confusing the IDE with a virus, and also lets you refer to the online documentation quickly whenever you need to.